Support Forum

version `GLIBC_2.34' not found

Speed

Wednesday 8th June 2022
I am trying to run layout editor in ubuntu but it appears my GLBC is not the correct version here is an output when running it ``` layout LayoutEditor installed at /opt/layout add shpped OpenROAD to PATH using openAccess library /opt/layout/oa OpenAccess libraries found at /opt/layout/oa use OpenAccess version 22.50 /opt/layout/bin/layout: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /opt/layout/bin/layout) /opt/layout/bin/layout: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.33' not found (required by /opt/layout/bin/layout) /opt/layout/bin/layout: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /opt/layout/bin/layout) ``` Im using ubuntu 20.04
J├╝rgen
LayoutEditorFull
Wednesday 8th June 2022
Did you install the correct LayoutEditor package for Ubuntu 20.04? The LayoutEditor always uses the library versions suppliered by the Linux system it is prepared for. From you error message it seems that newer version are requested than are present on Ubuntu 20.04. So you may have accidentally installed the package for Ubuntu 22.04?
Speed

Wednesday 8th June 2022
Oops! Yeah, I noticed i had both installers downloaded, so i think that was it. i just removed the other installer, then reinstalled with the correct version and it worked. sorry for the confusion. everything works now!