Support Forum

Liboaplugin version issue

Bo

Wednesday 9th September 2020
Hi all, I recently purchased another 5 years of subscription and thus upgraded to the latest version of LE and downloaded the latest version of PyCell from Synopsys. However, when trying to use it, LE throws out this error on command line: Requested minor API version '611' which is supported by OpenAccess build '22.60.028' is newer than the minor API version '607' of the shared library of OpenAccess build '22.60.021'. How can I solve it? LE: 20200801 PyCell: 20200527 OS: Ubuntu 20.04 Regards, B.G.
Jürgen
LayoutEditorFull
Wednesday 9th September 2020
Hi Bo, you need to install another version of PyCell. I recommend using a OpenAccess build 22.50.xxx. Sadly the PyCell package name does not say which OpenAccess build it uses. The package "PyCellStudio_installer_linux_gcc483_64_L-2019_06-SP1_Py262.tar.gz" was test and works for all platforms. It uses OpenAccess 22.50.011. Newer platforms like Ubuntu 20.04 will also run package for gcc62_64. But in any case if you are using the OpenAccess build 22.60.yyy you need at least build 22.60.028 to run with the LayoutEditor. Earlier versions of OpenAccess 22.60.yyy have issues and do not work.
Jürgen
LayoutEditorFull
Saturday 12th September 2020
Starting with LayoutEditor release 20200912 PyCell for OpenAccess 20.60.021 wiill be supported. The mentioned problem will be fixed for all Linux package of the LayoutEditor. The latest development version supporting it can be downloaded with this link: [https://layouteditor.com/download?release=latest](https://layouteditor.com/download?release=latest) PyCell for OpenAccess 20.60.021 is not yet available for Window and the LayoutEditor does not support 22.60 for Windows yet. Please use OpenAccess 22.50. OpenAccess is not available on Mac OSX.